내 파일이 SDMS에 캡처되지 않지만 TE_TEMP에 파일이 있습니다 - WKB2409
Article number: 2409To English version
증상
- 파일은 NuGenesis에 의해 보관을 위한 스캔 경로 (예:\\Filesserver1\shareddata\)에 있었지만 WebVision에는 표시되지 않습니다. TE_TEMP에는 NuGenesis 파일 캡처 프로세스의 보류 파일 위치에 있는 파일이 있습니다.
환경
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
- SDMS에 의해 파일을 캡처할 준비가 되었습니다.
- Archive Agent의 작업 로그에 따라 파일이 AA에 캡처되었습니다.
- 여러 파일이 SDMS 서버의 TE_TEMP 폴더에 있습니다.
원인
일반적으로 파일은 TE_TEMP 폴더에 짧은 기간 동안만 존재합니다. NuGenesis Archive Agent는 파일 캡처 프로세스 중에 해당 폴더에 파일을 복사하고, 전송 엔진 모듈은 파일을 TE_TEMP에서 데이터베이스로 또는 관리 저장소로 이동합니다. 이 디렉터리에 존속하는 파일은 Oracle 모듈 또는 관리 대상 스토리지로 파일을 전송하는 동안 TE 모듈이 중지되었거나 오류가 발생했음을 나타냅니다.
수정 또는 해결 방법
NuGenesis TE_TEMP 폴더에서 .mark_bad 파일을 찾으십시오.
- TE_TEMP에 .mark_bad 파일이 없으면 다음과 같이 하십시오.
- NuGenesis 서버에서 NuGenesis Service Configuration Console에 로그인하고 Transport Engine 모듈을 시작합니다.
- TE 모듈을 시작해도 문제가 해결되지 않으면 NuGenesis RPC Service를 NuGenesis 서버에서 재시작합니다.
- TE_TEMP에 .mark_bad 파일이 있는 경우:
- 파일 이름을 .NGD로 다시 변경합니다.
- 잠시 후 파일 이름이 .mark_bad로 재변경되면 NuGenesis RPC Service를 다시 시작합니다.
- 서비스를 다시 시작한 후에도 문제가 지속되면 메모장에서 최신 수정 날짜가 있는 .mark_bad 파일을 열고 파일의 끝까지 스크롤합니다. [NGXXXXX] 형식의 NG 오류 코드를 찾습니다.
- NuGenesis SDMS 오류 코드 목록
- "[NG14570] Unknown database error"는 아마도 .mark_bad 파일에서 가장 일반적인 오류 코드일 것입니다.
추가 정보
TE_TEMP 폴더는 일반적으로 서버의 NuGenesis 설치 경로 내에서 설정됩니다. 예:
- NuGenesis 9: Drive:\Program files (x86)\Waters\NGSDMS\TE_TEMP
- NuGenesis 8: Drive:\Program Files (x86)\NuGenesis 8.0\TE_TEMP
TE_TEMP 위치는 설정 가능한 설정입니다. TE_TEMP 경로가 확실하지 않은 경우 NuGenesis 서버에서 NuGenesis Service 설정 Console에 로그인하고 Archive Agent 모듈을 선택합니다. 경고 메시지가 표시되면 OK를 클릭합니다. 메타데이터 폴더 텍스트 상자에는 파일 캡처 모듈에서 사용하는 TE_TEMP 폴더의 전체 경로가 표시됩니다. 참고: 폴더의 이름을 TE_TEMP로 지정할 필요는 없습니다. 이 이름은 단지 기본 이름입니다. 또 다른 일반적인 이름은 " Pending" 입니다.
TE_Temp 위치에 .mark_bad 파일 수가 많으면 CMD 프롬프트를 사용하여 파일 확장명을 .ngd로 변경합니다.
- Windows CMD 프롬프트를 열고 디렉터리를 TE_Temp 위치로 변경합니다. 예: (Drive:\Program Files (x86)\NuGenesis 8.0\TE_TEMP
- CMD 타입 ren * .mark_bad * .ngd
- 그러면 모든 mark_bad 확장이 .ngd로 변경됩니다.
id2409, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG