메인 콘텐츠로 건너뛰기
Waters Korea

NuGenesis LMS-SDMS Interface Wizard에 로그인할 수 없음 - WKB18325

Article number: 18325To English version

증상

  • SDMS Extract Results Wizard에 로그인할 때 다음 메시지가 나타납니다.
    • "Login to LMS Failed: Please check connectstring and credentials."

환경

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

원인

  • SDMS2ELN.ini 파일의 로그인 자격 증명 또는 연결 URL이 유효하지 않습니다.
  • LMS- SDMS Interface가 LMS SDK와 동일한 버전이 아닙니다.

수정 또는 해결 방법

  1. LMS SDK 및 LMS- SDMS Interface에 대한 Auto IQ 프로그램을 실행합니다.
  2. IQ 로그 파일에서 마이너 버전 번호를 비교합니다.
    • 정상적으로 작동하는 예시: "NuGenesis LMS SDK 9.0.2 Service Release" 및 "NuGenesis LMS SDMS Interface V2.0.2"
    • 작동하지 않는 예시: "NuGenesis LMS SDK 9.0.2 Service Release" 및 "NuGenesis LMS SDMS Interface V2.0"
  3. 마이너 버전이 일치하지 않을 경우, 설치 미디어에서 올바른 버전의 LMS- SDMS Interface를 설치하십시오.
  4. 설정:
    1. NuGenesis LMS SDMS Interface 서비스를 중지합니다.
    2. C:\ProgramData\Waters\Sdms Result Extractor에서 SDMS2ELN.ini 파일을 편집합니다.
    3. ELNUser 및 ELNPasswd를 유효한 LMS 사용자 이름과 암호로 설정합니다.
    4. ELNConnect 문자열에 LMS 서버에 대한 올바른 호스트 이름 또는 정규화된 이름, 포트 번호 8180 및 "/vp/services/"가 있는지 확인합니다.
      1. NuGenesis 9.3의 경우 기본 포트 번호는 8443입니다
    5. 파일을 저장하고 닫습니다.
    6. 서비스를 시작합니다.
  5. NuGenesis LMS Server 서비스가 LMS 서버에서 시작되었는지 확인합니다. 사용자가 LMS에 로그인할 수 있는지 확인합니다.

추가 정보

LMS가 LDAP 인증을 위해 설정되었을 때 SYSTEM 계정으로 설정되었을 경우, 서비스의 로그 파일에 다음 메시지가 나타납니다.

"DATE TIME,942 [6] ERROR Waters.ELN.ToolKit.SessionContext [(null)] - logon failed with reason 4"

id18325, NGLMS, NGLMSLIC, NGLMSOPT, password, SUPNG, 비밀번호