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오류: Can't contact LDAP server (from SDMS Administrator for Secure LDAP connection test) - WKB7437

Article number: 7437To English version

증상

  • SDMS Administrator의 LDAP 인증 설정에서 SSL 또는 TLS가 활성화 됩니다.
  • Test Connection 버튼을 클릭하면 다음 메시지가 표시됩니다.
    • The following error occurred while trying to connect to server
      <host:port>
      [NG17543] LDAP driver reports error : Can't contact LDAP server
      (81)
      Can't contact LDAP Server
      Unable to bind to LDAP server

    • "호스트"는 LDAP 서버의 이름입니다. "포트"는 보안 LDAP 통신을 위한 서버의 TCP 포트입니다(이 포트 번호는 일반적으로 636임).

  • LDAP 인증 설정에서 SSL이 비활성화 된 경우 연결 테스트가 성공적으로 수행됩니다.

환경

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

원인

SSL/TLS를 사용할 때 연결 테스트가 실패하고 암호화가 없으면 성공할 경우, 문제는 NuGenesis 응용 프로그램 인증서 때문일 가능성이 큽니다. SDMS는 LDAP 서버의 ID를 확인하기에 충분한 인증서가 필요합니다. 이 인증서 집합는 일반적으로 Certificate Authority (CA)의 신뢰할 수 있는 루트 인증서로 구성되며, 인증 체인에 중간 CA가 있는 경우 둘 이상의 인증서로 구성될 수 있습니다. 필요한 정확한 인증서 집합은 고객마다 특이하며, 조직 내의 CA 구조에 따라 달라집니다.

수정 또는 해결 방법

  1. CA에 LDAP 서버 인증서 및 신뢰할 수 있는 루트 인증서의 사본을 요청합니다. 인증서 설치에 대한 지침은 다음 문서를 참조하십시오.
  2. SDMS Administrator에서 연결 테스트를 반복합니다.
  3. 그래도 테스트에 실패할 경우, SSLTap 도구를 사용하여 연결 문제를 해결하십시오. How to find a list of troubleshooting tools for NuGenesis softwareNuGenesis(소프트웨어의 문제 해결 도구 목록을 찾는 방법) 문서에서 SSLTap의 사본을 받는 방법을 확인하십시오. SSLTap 도구에 대한 지침은 How to use SSLTap to troubleshoot SSL connection errors(SSLTap을 사용하여 SSL 연결 오류를 해결하는 방법)을 참조하십시오.

추가 정보

 

id7437, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG

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