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Waters Korea

NuGenesis RPC 서비스가 실행 중이지만 NGD 파일이 TE TEMP 외부로 이동하지 않음 - WKB66330

Article number: 66330To English version

증상

  • NGD 파일이 NuGenesis TE_TEMP 폴더에 있지만 파일이 처리되지 않습니다.
  • NuGenesis RPC 서비스가 실행 중입니다.
  • Windows Task Manager에서 NGRPCService.exe 프로세스가 실행 중이지만 목록에 NGRPCShadowServer.exe 프로세스가 없습니다.
  • 전송 엔진이 시작되지 않습니다.

환경

  • NuGenesis 9 SDMS
  • NuGenesis 8 SDMS

원인

NuGenesis RPC Service 사용자의 Temp 폴더에 빈 "TETime.ini" 파일이 있습니다. 또는 "%APPDATA%"라는 파일이 C: 드라이브에 존재합니다.

수정 또는 해결 방법

  • 0 바이트 NGTETime.ini 파일 :
    1. NuGenesis RPC Service 계정의 Temp 폴더에서 TETime 파일을 찾습니다. Temp 폴더는 일반적으로 C:\Windows\Temp 또는 C:\Temp입니다. 서비스가 명명된 사용자 계정(로컬 또는 도메인 계정)으로 실행되는 경우 INI 파일은 C:\Users\username\AppData\Local\Temp에 있습니다.
    2. TETime 파일을 삭제합니다.
      • NuGenesis 9: NGTETime.ini
      • NuGenesis 8: NG80TETime.ini
    3. NuGenesis RPC Service를 다시 시작합니다.
    4. 이 문제로 인해 오류 CRI-611이 제기되었습니다. NuGenesis 9.0.2에서 문제가 해결되었지만, SDMS 소프트웨어가 새로 설치된 경우에만 가능합니다. 9.0.2 업데이트 프로그램에 오류 CRI-611에 대한 수정 사항이 포함되지 않았습니다. 이 수정 사항은 9.0.2로 업그레이드 된 시스템을 위한 소프트웨어 패치로 Waters와 별도로 제공됩니다. 이 패치를 얻는 데 도움이 필요하면 Waters 기술 지원부 또는 현장 서비스 엔지니어와 문의하십시오.
  • C:\ 드라이브의 파일:
    1. C:\ 폴더에서 %APPDATA%라는 파일을 찾습니다. 숨겨진 파일과 시스템 파일이 Windows 탐색기에 표시되는지를 확인하십시오.
    2. 이 파일이 발견된다면 삭제하십시오.

추가 정보

파일이 존재하지만 크기가 0 바이트인 경우 NuGenesis RPC Service는 이러한 문제가 발생합니다. 파일이 존재하지 않는 경우 서비스는 새 TETime 파일을 구축합니다. 이 문제로 인해 결함 보고서 CRI-611이 제기되었습니다.

또한 이 문제는 일부 경우에 데이터베이스 서버 재부팅으로도 해결되는 것으로 알려져 있습니다.

따로 관찰된 부분은 고객이 D:Drive에 TEMP 폴더를 생성했지만 원래 파일은 C:Temp 폴더 구조에서 찾을 수 없었고, 더 자세히 조사하면 별도의 드라이브에서 다른 TEMP 파일을 찾을 수 있었습니다. 위에서 언급한 디렉터리를 사용하여 즉시 해결되지 않는 경우 다른 드라이브를 확인해 볼 것을 권장합니다.

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