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사용자가 LDAP 자격 증명으로 NuGenesis LMS에 로그인할 수 없음 - WKB65472

Article number: 65472To English version

증상

  • NuGenesis LMS 사용자가 시스템에 로그인할 수 없습니다.
  • 반복적으로 로그인을 시도하는 사용자에 대해 LMS는 계정을 잠급니다.
  • LMS 서버의 server.log 파일에 다음의 오류 메시지가 나타납니다.
    • ERROR [com.creon.common.secure.LDAPAuthentificator] (http-0.0.0.0-8180-10) Problem accessing LDAP Server, e.g user not available in LDAP: javax.naming.CommunicationException: LDAPServerName:636 [Root exception is java.net.ConnectException: Connection timed out: connect]

환경

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • LMS는 LDAP 인증을 위해 설정되었습니다.

원인

LMS 서버는 기본 또는 보조 LDAP 서버에 연결할 수 없습니다.

수정 또는 해결 방법

  1. LDAP 서버가 온라인 상태인지 확인합니다.
  2. LMS 서버의 바탕 화면에 로그온하고 nslookup 도구를 사용하여 LMS가 LDAP 서버의 도메인 이름에 대해 수신하는 IP 주소를 확인합니다. 이 IP 주소를 LDAP 서버의 알려진 IP 주소와 비교합니다.
    • IP 주소가 올바르지 않으면 LMS 서버가 DNS에서 잘못된 IP를 가져오는 것입니다.
    • IP 주소가 정확하지만 LMS가 여전히 LDAP에 연결할 수 없는 경우라면 LDAP 서버는 오프라인 상태일 수 있습니다.
  3. 대부분의 솔루션은 네트워크 및/또는 LDAP 관리자의 조치와 피드백이 필요하므로 서버 가용성이나 이름 확인 문제를 해결하려면 적합한 담당자와 협력해야 합니다.

추가 정보

 

id65472, ELN, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG