메인 콘텐츠로 건너뛰기
Waters Korea

NuGenesis LMS의 Java Heap Space 튜닝 - WKB3269

Article number: 3269To English version

증상

  • 사용자가 NuGenesis LMS 클라이언트를 통해 문서를 열 때 오류 메시지가 나타날 수 있습니다.
  • LMS 클라이언트의 로그 파일에 기록된 오류 메시지는 (부분적으로) "Caused by: java.lang.OutOfMemoryError: Java heap space"라고 표시합니다.
  • 이 오류는 큰 문서(크고 해상도가 높은 이미지가 있거나 많은 문서 섹션이 있는 문서)에서 발생할 가능성이 큽니다.

환경

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

원인

Java 런타임 환경은 서버가 사용자 요청(예: 문서 열기)을 처리하기에 충분한 메모리를 LMS 서버에 할당할 수 없습니다.

수정 또는 해결 방법

  1. 메모장에서 Drive:\WatersLMSServer\javaServiceWrapper\conf\wrapper-jboss.conf 파일을 엽니다.
  2. 다음 텍스트를 보십시오:
    • # Maximum Java Heap Size (in MB).
    • wrapper.java.maxmemory=
  3. wrapper.java.maxmemory의 기본값은 1024입니다. 해당 숫자를 다른 숫자(예: 4GB 단위로 4096)에 해당하는 숫자로 변경합니다.
  4. 파일을 저장하고 닫습니다.
  5. NuGenesis LMS Server 서비스를 다시 시작합니다.

추가 정보

NuGenesis LMS Server는 Java 런타임 환경에서 실행되는 64비트 응용 프로그램입니다. JRE는 해당 초기화 매개 변수에 따라 시스템에서 메모리를 할당하고, 환경 내에서 실행되는 Java 응용 프로그램에 메모리를 할당합니다(LMS 서버의 경우 LMS 서버 서비스는 하나뿐입니다). 모든 설치에 대해 JRE heap 할당 한계를 4GB로 높이고, 서버 로드에 대해 4GB가 충분하지 않을 경우 JRE의 heap 할당 한계를 4GB로 늘리는 것이 좋습니다. LMS의 모든 사용자 작업은 일부 메모리 사용을 필요로 하며 더 이상 필요없는 메모리는 해제되지만, 일부 작업의 경우 메모리를 더 많이 할당해야 할 수 있습니다.

LMS 클라이언트의 로그 파일은 사용자 프로파일 폴더 내의 AppData 폴더에 저장됩니다. LMS 클라이언트가 사용자의 PC에서 로컬로 실행되는 경우, AppData 폴더 (및 LMS 로그 파일은 PC에 로컬로 저장 됨), LMS가 Citrix 클라이언트를 통해 실행되는 경우, 로그 파일은 Citrix 서버의 사용자 프로파일 폴더에 있습니다. 로그 파일을 찾는 데 추가로 복잡 할 수 있는 문제는 하나의 팜에 여러 Citrix 서버가 있고 (사용자가 팜 내 다른 서버로 리디렉션되거나) Citrix 프로파일 관리가 사용중인 경우에 발생할 수 있습니다. 프로파일 관리에는 여러 가지 양식이 있지만 일반적으로 , 개별 Citrix 서버가 아니라 중앙 서버에 사용자 프로파일을 저장합니다 .LMS가 로컬 PC에서 실행되는 경우, 로그인 한 상태에서 PC의 시작> 실행 프롬프트에 다음 경로를 지정하여 로그 파일을 찾습니다. 특정 사용자로 PC에 연결 :

  • NuGenesis 8/9 LMS: %AppData%\Waters\NuGenesis LMS\version\Product.log
  • NuGenesis 8 ELN: %AppData%\Waters\NuGenesis ELN\version\Product.log

id3269, ELN, memory, NGLMS, NGLMSLIC, NGLMSOPT, SUPNG