메인 콘텐츠로 건너뛰기
Waters Korea

NuGenesis LMS Toolbox를 사용할 때 "Failed to connect to Oracle database" 오류가 표시됨 - WKB29852

Article number: 29852To English version

증상

  • NuGenesis LMS Toolbox를 통해 데이터를 내보내거나 가져올 때 다음 메시지가 나타납니다.
    • "Failed to connect to the Oracle database"
  • Toolbox 인터페이스에서 선택한 Oracle Service가 유효하고 데이터베이스 자체가 실행 중입니다

환경

  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

원인

  1. Oracle 클라이언트(예: NuGenesis와 함께 제공되는 Waters Oracle Client)가 설치되었지만 선택한 서비스 이름이 클라이언트의 tnsnames.ora에 없습니다.
  2. Toolbox에 ELNPROD 사용자의 잘못된 암호가 지정되었습니다.

수정 또는 해결 방법

  1. Oracle 클라이언트 설정을 확인합니다.
    1. Start 메뉴 또는 화면에서 Waters Net Configuration Assistant를 실행합니다.
    2. Toolbox에서 선택된 "Oracle Service"는 클라이언트의 tnsnames.ora 파일에 있는 별칭과 일치해야 합니다.
      1. 예: Toolbox에서 "SDMS8.WORLD"가 선택된 경우, Configuration Assistant에는 Alias가 "SDMS8"인 항목이 있어야 합니다
    3. 선택한 Alias에 항목이 없는 경우 파일에 항목을 생성합니다
      • 종종 올바른 데이터베이스 호스트, 서비스 이름 및 포트 번호가 파일에 있지만 이름은 다릅니다.
      • 이 경우 새 줄을 만들고 올바른 별칭을 지정한 다음 기존 항목에서 호스트 이름, 서비스 이름 및 포트 번호를 복사합니다.
    4. 수정된 설정을 저장합니다.
  2. ELNPROD에 대한 올바른 암호를 지정합니다.
    1. 도구 상자의 "User" 목록은 데이터베이스의 Oracle 계정 목록을 표시합니다. Toolbox에는 "ELNPROD"만 사용해야 합니다.
    2. 암호 상자에 ELNPROD의 올바른 암호를 지정합니다.
    3. 암호의 기본값은 "elnprod"이지만 NuGenesis 8의 ELNPROD 계정에 대한 기본 암호는 아닙니다.
    4. Next 버튼을 클릭하여 데이터베이스와의 연결을 확인합니다.
  3. 데이터베이스에 대한 연결이 여전히 실패하면 Toolbox 로그 파일에서 자세한 내용을 확인하십시오.
    1. 기본 로그 파일 위치는 %TEMP%\Toolbox.log입니다.
    2. Toolbox 설치 폴더의 ELNToolbox.exe.config 파일에서 로그 파일의 경로를 찾습니다.

추가 정보

Toolbox는 Set Preferences 메뉴를 통해 Toolbox에 설정된 설정 파일에서 Oracle Service 목록을 가져옵니다. 이 경로는 종종 NuGenesis Oracle 서버의 Oracle Home 경로이거나, 또는 적어도 완전한 Oracle 11g 클라이언트 홈 목록입니다. Toolbox는 내보내기 또는 가져오기를 위해 데이터베이스에 연결하려고 시도할 때 TNS_ADMIN 시스템 변수를 통해 연결합니다. 이 변수는 종종 Waters Oracle Client for NuGenesis와 같이 Toolbox에 설정된 Oracle Home과 다른 Oracle 클라이언트 설치를 가리킵니다. 모든 Oracle 클라이언트의 tnsnames.ora 및 sqlnet.ora 파일에 NuGenesis 데이터베이스에 대한 동일한 연결 정보가 있는지 확인합니다.

id29852, NGLMS, NGLMSLIC, NGLMSOPT, password, SUPNG, 비밀번호