오류: NuGenesis Restore 또는 Preview에 "Failed to extract file(s) to folder..." 메시지가 표시됨 - WKB7353
Article number: 7353To English version
증상
- NuGenesis에서 파일 데이터를 복원하거나 인쇄 데이터를 열 때 다음 오류 메시지가 나타납니다.
"Failed to extract file(s) to folder<temp path>. Please ensure that there is sufficient disk space for file. If there is sufficient disk space please try again as the network\DB connection may have been lost."
환경
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
원인
일반적으로 이 메시지는 저장 공간 부족을 나타내지 않습니다. 이 오류 메시지의 가장 일반적인 원인은 (1) 파일이 오프라인 스토리지로 이동되었고 오프라인 스토리지 장치가 오프라인 상태이거나 (2) 파일이 Managed Storage 프로젝트에 있고 프로젝트의 FTP 저장 위치가 사용 불가한 상태입니다. 이 문서에서는 Oracle 데이터베이스, Managed Storage 또는 오프라인 장치에서 요청된 파일의 저장 위치를 확인하는 단계에 대해 설명합니다.
수정 또는 해결 방법
- 사용자가 NuGenesis 설치 폴더 및 모든 하위 폴더에 대한 읽기/쓰기 권한을 가지고 있는지 확인합니다.
- NuGenesis 9: Drive:\Program Files (x86)\Waters\NGSDMS
- NuGenesis 8: Drive:\Program Files (x86)\NuGenesis 8.0
- 레코드가 Offline 스토리지 및/또는 Managed Storage 프로젝트에 있는지 확인합니다.
- NuGenesis WebVision에서 파일 레코드를 선택하고 File 메뉴 > View Details > File properties를 클릭합니다.
- Moved Out Status 열에 "Moved out" 또는 "Uploaded"라고 표시되면 해당 파일이 오프라인 스토리지 장치에 있는 것입니다. Moved Out Volume Name, Moved Out Device Name 및 Moved Out File Name을 기록한 다음 오류: NuGenesis Restore for an Offline 파일에 "Failed to extract file(s) to folder..." 메시지가 표시됨 문서의 지침에 따라 문제를 해결하십시오.
- 열에 "Not moved out"라고 표시되면 해당 파일이 오프라인 저장 장치에 없습니다. 이 파일은 Managed Storage 사이트 또는 Oracle 데이터베이스에 있습니다.
- SDMS Administrator에 로그인합니다.
- SDMS 프로젝트에 대한 속성 페이지를 엽니다. 프로젝트 속성 페이지에서 "Managed Storage Locations" 탭을 선택합니다.
- Managed Storage 위치가 프로젝트에 나열된 경우,이 파일은 Managed Storage 사이트에 있습니다. 문서 Managed Storage 프로젝트의 NuGenesis Restore에 오류: "Failed to extract file(s) to folder..."라는 메시지가 표시됨의 지침에 따라 문제를 해결하십시오.
- 파일이 오프라인 스토리지 장치에 저장되지 않고 프로젝트가 Managed Storage 사이트를 사용하지 않는 경우 파일은 Oracle 데이터베이스에 있어야 합니다.
- NuGenesis 서버의 Windows 방화벽이 NuGenesis RPC Service의 기본 포트에서 트래픽을 허용하는지 확인하십시오.
- 클라이언트/Citrix 시스템의 다음 레지스트리 키에서 설정한, NuGensis Transfer App이 사용하는 Temp 폴더의 위치를 확인합니다.
- HKLM\SOFTWARE\WOW6432Node\NuGenesis Technologies Corp.\NuGenesis\Preview\TempFolder
- Transfer App이 로그인한 사용자의 임시 폴더를 사용하도록 이 키를 %TEMP%로 설정해야 합니다.
- 파일이 Oracle 데이터베이스에 있고 NuGenesis 서버의 방화벽이 NuGenesis RPC Service 포트의 트래픽을 차단하고 있지 않지만 문제가 지속되면 Waters 기술 지원부에 지원을 요청하십시오.
추가 정보
데이터 복원을 시도하는 사용자에게는 대상 복원 위치에 대한 권한이 있는지 확인하십시오.
시스템 설정 후 LDAP를 변경할 경우 NuGenesis RPC Service를 다시 시작합니다
id7353, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG