메인 콘텐츠로 건너뛰기
Waters Korea

NuGenesis LMS 클라이언트에 로그인할 때 "LMS server is not available" 오류가 발생함 - WKB48402

Article number: 48402To English version

증상

  • NuGenesis LMS에 로그인할 때 다음 오류 메시지가 나타납니다.
    • "LMS server is not available"

환경

  • NuGenesis 9 LMS
  • NuGenesis 8 LMS
  • NuGenesis 8 ELN

원인

  • NuGenesis LMS용 Oracle 데이터베이스가 다운되었습니다.
  • NuGenesis LMS Server 서비스가 중지되었습니다.
  • 클라이언트 시스템이 LMS 서버의 호스트 이름 또는 완전 Qualification된 도메인 이름을 확인할 수 없습니다.

모든 LMS 사용자가 이 메시지를 받으면 Oracle 또는 LMS 서버에 문제가 있을 수 있습니다. 하나의 사용자 또는 소수의 사용자에게만 영향을 미칠 경우, 클라이언트 시스템에 문제가 있을 수 있습니다.

수정 또는 해결 방법

  1. Oracle 데이터베이스가 온라인 상태이고 열려 있는지 확인합니다.
    1. NuGenesis LMS/SDMS 인스턴스에 대한 경고 로그에서 인스턴스 시작을 방해하는 최근 오류가 있는지 확인합니다.
    2. Windows의 Oracle 데이터베이스의 경우 "OracleServiceSDMS" 및 OracleSDMSTNSListener" 서비스가 모두 시작되고 자동 시작을 위해 설정되었는지 확인합니다.
  2. NuGenesis LMS Server 서비스를 시작하거나 다시 시작합니다.
    1. 원격으로 LMS 서버 시스템으로 이동하여 "NuGenesis LMS Server" 서비스가 시작되고 자동 시작을 위해 설정되었는지 확인합니다.
    2. 오류 상태에 있는 동안 서비스가 시작되고 계속 실행될 수 있습니다. 그 이유에 대해서는 Drive:\WatersLMSServer\log\server.log에서 최근 오류에 대한 로그 파일을 검토하십시오.
  3. 클라이언트 시스템이 서버의 호스트 이름 또는 Qualification된 도메인 이름을 확인할 수 있는지 확인합니다.
    1. LMS 서버로 원격 연결하여 바탕화면 또는 Start 화면에서 "NuGenesis LMS IIS Configuration" 도구를 실행합니다.
    2. 설정 도구에서 Next를 클릭합니다.
    3. 테이블의 Server Host 열에 항목을 기록합니다. 첫 번째 항목은 일반적으로 동일한 서버 시스템이며 항목 1과 2는 일반적으로 대체 LMS 서버/환경이며 테이블에 없을 수 있습니다.
    4. 명령 프롬프트를 열고 ipconfig 도구를 실행하여 서버의 IP 주소를 가져옵니다.
    5. 클라이언트 시스템에서 명령 프롬프트를 열고 ping.exe 도구를 사용하여 LMS 서버의 호스트 이름과 완전 Qualification된 이름을 ping 합니다.
      1. Ping 도구에 의해 반환된 IP 주소가 ipconfig 도구의 출력에 표시된 것과 일치하지 않을 경우, DNS 해결 프로그램이 이름에 대해 잘못된 IP 주소를 반환하거나 localhosts 파일에 해당 이름에 대한 잘못된 IP를 포함하는 항목이 있는 것 같습니다.
      2. 다른 서브넷에 있는 다른 클라이언트에서 이 테스트를 반복합니다.
      3. 호스트 시스템 이름이나 완전 Qualification된 도메인 이름을 사용하도록 LMS IIS Configuration을 편집합니다. 이 이름은 클라이언트 시스템에서 더 넓게 해석될 수 있습니다.
  4. NuGenesis LMS 서버의 Windows 방화벽이 포트 8180으로의 인바운드 트래픽을 허용하는지 확인합니다.
    • LMS 클라이언트가 여전히 서버에 연결할 수 없는 경우, 클라이언트 시스템과 서버 사이의 연결을 차단할 수 있는 네트워크 수준 방화벽에 대해 네트워크 관리자와 상의하십시오.
  5. module.xml에 유효하지 않은 글꼴 참조가 없는지 확인
    • LMS 서버에서 '<Drive>:\WatersLMSServer\Wildfly-11.0.0.Final\modules\system\layers\base\waters\lms\reports\main' (v8에서 다른 경로)로 이동하고 module.xml 파일을 엽니다. 참조된 모든 글꼴 파일이 유효한지 확인합니다. 존재하지 않는 글꼴 파일에 해당하는 행을 제거하거나 주석 처리한 다음 NuGenesis LMS Server Service를 다시 시작합니다.

추가 정보

 

id48402, ELN, NGLMS, NGLMSLIC, NGLMSOPT, review, SUPNG, 리뷰