NuGenesis SDMS Archive Agent가 시작되지 않고 로그 파일에 기록되지 않음 - WKB251394
Article number: 251394To English version
증상
- Archive Agent가 NuGenesis Service Configuration Console (SCC)에서 시작되지 않습니다.
- AA는 일반 로그 파일 NGSDMSAAActivity.log를 기록하지 않습니다.
- SDMS File Capture 구성 요소의 Auto IQ 로그 파일은 깨끗합니다. 오류나 경고가 없습니다.
환경
- NuGenesis 9 SDMS
- NuGenesis 8 SDMS
원인
하나의 DLL 파일 NGArchiveAgentDll.dll이 등록되지 않았습니다.
수정 또는 해결 방법
- NuGenesis RPC Service를 중지합니다.
- 관리자 권한으로 명령 프롬프트에 DLL을 등록합니다
- NuGenesis 9: C:\Windows\Microsoft.Net\Framework\v4.0.30239\regasm.exe "Drive:\Program Files (x86)\Waters\NGSDMS\Common Files\NGArchiveAgentDLL.dll" /codebase /verbose
- NuGenesis 8: C:\Windows\syswow64\regsvr32.exe "Drive:\Program Files (x86)\NuGenesis 8.0\Common Files\NGArchiveAgentDll.dll"
- NuGenesis RPC Service를 다시 시작합니다.
- SCC에 로그인하고 AA 모듈이 시작되었는지 확인합니다.
추가 정보
NuGenesis 9는 DLL을 등록하기 위해 다른 절차가 필요합니다. 코드가 Microsoft.NET Framework을 사용하도록 재작성되었기 때문입니다. 이 코드는 DLL의 NG9 버전을 .NET 어셈블리로 만듭니다. 이러한 DLL에는 "DllRegisterServer" 기능이 없으므로 regsvr32.exe와 호환되지 않습니다. 파일의 NG8 버전은 .NET Framework를 사용하지 않으므로 regsvr32.exe에 등록됩니다.
이 문제에 대한 개선 요청 CRI-5410이 제출되었습니다.
id251394, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG