NuGenesis SDMS SDK를 사용하여 LDAP/TLS를 통해 SDMS에 로그인할 때 "[NG17538] Unable to create LDAP session" 오류가 발생함 - WKB209611
Article number: 209611To English version
증상
- 유효한 LDAP 자격 증명으로 로그인할 때 SDMS SDK에서 다음 오류 메시지가 반환됩니다.
- [NG17538] Unable to create LDAP session
환경
- NuGenesis 9 SDMS
- TLS는 LDAP 인증을 위해 SDMS에서 활성화됩니다
원인
SDK 응용 프로그램은 NuGenesis SDMS 설치 폴더의 CACerts.cer 파일에 액세스할 수 있는 권한이 없습니다. 또는 사용자에게 해당 폴더에 대한 권한이 있지만 SDK 앱이 동시 사용자 세션을 처리합니다. 후자의 경우, 사용자 세션이 CACerts.cer에 액세스 할 때 충돌이 발생하여 NG17538 오류가 자주 발생합니다.
수정 또는 해결 방법
- 단일 사용자 SDK 응용 프로그램(즉, 한 번에 두 개 이상의 사용자 세션을 처리할 것으로 예상되지 않는 앱)의 경우: 드라이브:\Program Files (x86)\Waters\NGSDMS\Common Files에 대한 수정 액세스 권한을 Authenticated Users 그룹에게 부여합니다.
- 다중 사용자 SDK 응용 프로그램의 경우 유일한 해결 방법은 해당 앱에서 LDAP 계정을 사용하지 않는 것입니다. SDK 앱에 액세스해야 하는 각 사용자의 데이터베이스에 Oracle 계정을 생성합니다(Oracle 사용자 이름은 LDAP 사용자 이름과 구분되어야 함). SDMS Administrator 또는 SDMS Help Desk web 앱에서 일치하는 SDMS 사용자 계정에 Oracle 사용자 이름을 할당합니다.
추가 정보
이 문제에 대한 개선 요청 CRI-3909가 제출되었습니다.
id209611, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG, user account
id209611, SDMS, SDMS8, SDMS8NU, SUPISDMS, SUPNG, user account